V3 Content Library instability

Incident Report for Proposify

Resolved

This incident should now be resolved. The Content Library functions have returned to normal operation.
Posted Oct 17, 2025 - 13:42 ADT

Investigating

The content library is not saving properly at the moment. We're working on a fix.
Posted Oct 17, 2025 - 10:58 ADT
This incident affected: Proposal Editing.