Some of our Third Party Integrations are down.
Incident Report for Proposify
Resolved
All third integrations are up and running
Posted Oct 22, 2016 - 09:50 ADT
Identified
Some of our integration partners are currently experiencing technical difficulties and outages due to a DDoS attack. As a result, some of our third party integrations are temporarily disabled.
Posted Oct 21, 2016 - 13:56 ADT