Proposify is down for maintenance
Incident Report for Proposify
Resolved
We are fully operational again.
Posted Jan 26, 2019 - 11:23 AST
Identified
We're doing scheduled maintenance from 9-10am EST
Posted Jan 26, 2019 - 10:00 AST
This incident affected: Proposal Previews, Proposal Editing, Third Party Integrations, and Email System.