We are investigating reports of degraded performance
Incident Report for Proposify
Resolved
This incident has been resolved.
Posted Feb 01, 2024 - 16:40 AST
Investigating
We are currently investigating this issue.
Posted Feb 01, 2024 - 16:19 AST
This incident affected: Proposal Previews, Proposal Editing, Third Party Integrations, and Email System.