We are currently experiencing delays and downtime.

Incident Report for Proposify

Resolved

We have identified the issue and have resolved the root cause. We are now running at full speed.
Posted Apr 20, 2017 - 21:48 ADT

Investigating

Our team is investigating the issue and will provide an update soon.
Posted Apr 20, 2017 - 20:24 ADT