Proposify app is not loading properly
Incident Report for Proposify
Resolved
This incident has been resolved.
Posted May 17, 2023 - 15:42 ADT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 17, 2023 - 15:39 ADT
Investigating
We are currently experiencing an issue with the Proposify app loading properly for all users. We are investigating the root cause of the issue now.
Posted May 17, 2023 - 15:14 ADT
This incident affected: Proposal Previews, Proposal Editing, Third Party Integrations, and Email System.