We are currently experiencing degraded performance and are monitoring the situation.
Incident Report for Proposify
Resolved
The issue has been resolved and all systems are fully operational.
Posted Jan 30, 2018 - 19:33 AST
Investigating
Our team is currently investigating the issue.
Posted Jan 30, 2018 - 18:58 AST