SSL Certification Incident
Incident Report for Proposify
Resolved
This incident has been resolved.
Posted Jul 19, 2021 - 20:29 ADT
Update
We've tested our accounts locally and custom domains appear to be loading correctly once again. We will continue to monitor the situation until we receive the "all clear" from our provider.
Posted Jul 19, 2021 - 17:08 ADT
Update
Our SSL certification provider has resumed issuance and are monitoring closely to ensure the problem has been resolved.
Posted Jul 19, 2021 - 16:35 ADT
Update
We are continuing to monitor for any further issues.
Posted Jul 19, 2021 - 16:25 ADT
Monitoring
Our SSL provider is currently facing an outage. Preview links on accounts using custom domains will experience degraded service, including outage. Accounts not using custom domains should be unaffected. We've reached out to our certification provider and are monitoring closely for updates.
Posted Jul 19, 2021 - 16:24 ADT
This incident affected: Proposal Previews.