Login Issues

Incident Report for Proposify

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 17:13 ADT

Monitoring

A fix has been identified and we are working on it
Posted Jul 24, 2026 - 14:58 ADT

Investigating

We are currently monitoring the login issues with the application.
Posted Jul 24, 2026 - 14:47 ADT