Issue with 3rd party service provider
Incident Report for Proposify
Resolved
The issue has been resolved and all systems are fully operational.
Posted Sep 14, 2017 - 17:46 ADT
Investigating
The server that manages our images is experiencing problems globally. Their team is working on it and our team is monitoring the situation.
Posted Sep 14, 2017 - 16:45 ADT