We are experiencing a slow down in the system
Incident Report for Proposify
Resolved
Proposify is running at full capacity again. Contact support@proposify.biz if you encounter any further issues.
Posted Oct 28, 2016 - 13:16 ADT
Identified
Proposify is back up and running although you may still experience some slowness in the system. We are continuing to work on this issue.
Posted Oct 28, 2016 - 11:44 ADT
Update
We’re experiencing database issues right now and need to take the site down to investigate. You can still contact support by email support@proposify.biz Please check back to this page for updates.
Posted Oct 28, 2016 - 11:18 ADT
Investigating
There is a issue with loading our pages and we are looking into it. Updates coming soon
Posted Oct 28, 2016 - 10:43 ADT