Document Sending Issues

Incident Report for Proposify

Resolved

This incident has been resolved
Posted Aug 27, 2026 - 08:13 ADT

Identified

We are currently experiencing issues with the document send functionality. The issue has been identified and a fix in is progress.
Posted Aug 26, 2026 - 20:43 ADT
This incident affected: Email System.