We are currently experiencing service interruptions.
Incident Report for Proposify
Resolved
The issue has been resolved and all systems are fully operational.
Posted Jan 30, 2018 - 17:54 AST
Investigating
Our team is currently investigating the cause.
Posted Jan 30, 2018 - 17:46 AST