Custom Domains Issues

Incident Report for Proposify

Resolved

This incident has been resolved.
Posted May 08, 2026 - 18:07 ADT

Investigating

We're currently having infrastructure issues which may impact proposal previews under custom domains.
We are working with our service provider for a prompt resolution.
Posted May 08, 2026 - 16:52 ADT
This incident affected: Proposal Previews.