Proposify is currently down for maintenance.
Incident Report for Proposify
Resolved
We are back up and running!
Posted Dec 03, 2016 - 12:40 AST
Update
The update is taking longer than anticipated as we are currently running into deployment issues. More updates to follow.
Posted Dec 03, 2016 - 11:11 AST
Identified
The update is schedule to run from 9:00am to 10:00am Eastern .
Posted Dec 03, 2016 - 10:02 AST