We're currently upgrading Proposify
Incident Report for Proposify
Resolved
Maintenance has be completed and we are back up and running.
Posted Nov 25, 2017 - 11:34 AST
Identified
The update begins at 10:00am Eastern and will be complete at 1:00pm Eastern.
Posted Nov 25, 2017 - 10:07 AST