Service degradation

Incident Report for Proposify

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 10:23 ADT

Investigating

We are experiencing service degradation caused by our hosting provider. Users can encounter application latency. We are monitoring the situation and will keep regular updates.
Posted Oct 20, 2025 - 13:19 ADT
This incident affected: Proposal Previews, Proposal Editing, Third Party Integrations, and Email System.