Performance degradation affecting document editor and preview

Incident Report for Proposify

Resolved

This incident has been resolved.
Posted Dec 09, 2025 - 12:36 AST

Update

The issue has been resolved and the services are back to normal.
Posted Dec 09, 2025 - 12:36 AST

Investigating

We are currently experiencing slowed performance that is affecting the document editor and the preview experience. You may notice delays or errors when loading or editing documents. Our team is actively investigating the cause and working to restore normal performance as quickly as possible
Posted Dec 09, 2025 - 11:40 AST
This incident affected: Proposal Previews and Proposal Editing.