All systems are fully operational.
Incident Report for Proposify
Resolved
This incident has been resolved.
Posted Dec 11, 2018 - 12:05 AST
Monitoring
We are continuing to monitor issues with proposify.com. However, the app remains fully operational so you can login directly app.proposify.com
Posted Nov 27, 2018 - 10:39 AST