Service degradation

Incident Report for Proposify

Resolved

We have confirmation from our provider that the incident has been resolved.
Posted Feb 10, 2026 - 18:53 AST

Monitoring

We can confirm significant recovery from our provider although some customers could still experience delays or errors. We continue to monitor the situation toward full recovery
Posted Feb 10, 2026 - 18:06 AST

Identified

We're currently having infrastructure issues which may impact some site functionality. We are working with our service provider for a prompt resolution.
Posted Feb 10, 2026 - 17:19 AST
This incident affected: Proposal Previews and Proposal Editing.