New Proposify documents list service degradation

Incident Report for Proposify

Resolved

The incident has been resolved
Posted Aug 15, 2026 - 11:26 ADT

Monitoring

Issue has been resolved and we are monitoring
Posted Aug 15, 2026 - 10:57 ADT

Identified

WE have identified the issue and working on a fix
Posted Aug 15, 2026 - 10:45 ADT

Investigating

We are currently investigating an issue with the new. Proposify document list. Documents are taking a very long time to load or do not load at all.
Posted Aug 15, 2026 - 08:53 ADT
This incident affected: Proposal Editing.