Proposify.com experiencing issues.
Incident Report for Proposify
Resolved
We are fully operational again.
Posted Nov 27, 2018 - 10:17 AST
Update
We are continuing to investigate this issue.
Posted Nov 27, 2018 - 10:16 AST
Investigating
If you are trying to access our app, you can log in directly app.proposify.com. We are currently experiencing issues with proposify.com and hope to have the problem fixed as soon as possible.
Posted Nov 27, 2018 - 09:37 AST